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1 Introduction 
This document is here to make installing the app easier, help avoid mistakes and provide 
tips for fixing common problems. By following this guide, users can confidently set up the 
Digital Document Reader for the best performance. 

2 What is Document Reader (DDR)? 

Certificates, permits, and licenses issued by the SFA can be pre-viewed and printed through 
the Digital Document Reader. This application ensures the authenticity of the documents 
and allows users to review the content before printing a secure version that includes all 
watermark features. 

 

Figure 1: Digital Document Reader 

Note: document shown in preview does not bear the watermark features. Please do not 
share the document with foreign competent authority as it cannot be authenticated. 

3 What version of DDR should I use? 

Current Version 2.0.0.3 

Always use the latest version available. 
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4 What do I need on my computer or device to run this? 

Operating System Must be a Windows Operating System: 

Windows 10 or later with .NET Framework 4.8 

(Normally, Windows 10 and Windows 11 come with .NET 

Framework 4.8 pre-installed) 

Network Requires internet connectivity 

Table 1: System requirements 

5 How to install Digital Document Reader?  

Digital Document Reader (DDR) is available in the Microsoft Store. This makes it easy 
for users to download and install it directly on their Windows devices. 

5.1 Steps to Install from Microsoft Store 

(a) Open the Microsoft Store 

• Open the Start menu (in Windows OS) and type "Microsoft Store" in the 
search box. 

• Click on the Microsoft Store app to launch it. 
 

 

Figure 2: Microsoft Store App (Windows 11) 
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(b) Sign In to Microsoft Store (Optional) 

• You do not need to Sign-In to download the Digital Document Reader, it is 
recommended though as it will help to sync your apps across devices. To 
Sign-In click on the profile icon in the top right corner and sign in with your 
Microsoft account. 
 

(c) Search for the Application, “Digital Document Reader” 

• Use the search bar at the top of the Microsoft Store window to type in the 
name of the application. 

• Press [Enter] or click the search icon. 
 

 
 

Figure 3: Digital Document Reader in the MS Store 
 

(d) Select the Application 

• Browse the search results, locate the application, and click on the “Install” 
button to install the Digital Document Reader. 
 

 
 

Figure 4: Install button to directly install the app 
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(e) Wait for Installation to finish 

• The application will begin downloading and installing. You can see the 
progress in the Microsoft Store window or in the taskbar. 

 

 
 

Figure 5: Installation  in progress 

 
 

Figure 6: Installation confirmation 
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(f) Pin DDR to Start or Taskbar (Optional) for easy and quick access. 

• For quick access, you can right-click on the application in the Start menu and 
choose [Pin to Start] or More > Pin to taskbar to create a short cut to the 
application. 
 

 

Figure 7: Pin to taskbar or Start  
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6 How to use Digital Document Reader?  

6.1 Download (.dfx) document 
Ensure, you have the .dfx downloaded from GoBiz, Go to GoBiz frontend, find the 
licence record, click on Select Action > Download 

 

Figure 8: License Records 

A download popup screen shall appear, click on Download all files. DFX version of the 
licence certificate will be downloaded on user’s PC 

 

Figure 9: File listing 

Note: The downloaded files may be in a compressed format (.zip). You might need to 
extract them, and it's advisable to rename the files to shorter names for better 
readability. To extract a ZIP file ensure you have downloaded and install tools like 7-
Zip or WinZip. Right-click on the ZIP file, select “Extract Here” or “Extract to [folder 
name]” from the context menu, and follow any additional prompts if necessary. 
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6.2 Launch the application 
Select [Start] and enter ‘Digital Document Reader’, if you see it in the results, click 
‘Open’ to run the application. 

 

Figure 10: Search in Windows Start 

6.3 Opening a (.dfx) document 
Once the Digital Document Reader (DDR) is installed on a Windows computer, it will 
automatically become the default app for opening DFX files. These files will also show 
the DDR icon, making it easy to open them by double-clicking. 

Navigate to File > Open and select the downloaded .dfx file from your device. 

 

Figure 11: Opening DFX files. 
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The reader will show messages related to printing or other relevant information from 
the issuer; please do take note of the following message that is displayed before 
proceeding: “This copy is for your preview only as it does not bear the watermark 
features. Please do not share this with foreign competent authority as it cannot be 
authenticated.” Click 'Continue' to proceed. 

 

Figure 12: Message Dialog 

 

Figure 13: Document for preview in the reader 

If the document doesn’t open, first check that your internet connection is active. If 
your connection is fine but the reader still can’t open the document, make sure you’re 
opening the extracted .dfx file. If the issue continues, refer to the troubleshooting 
section for further diagnosis. 
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6.4 Check Document Validity (if necessary) 
DFX documents have a validity period, and you can verify the validity of the 
document if necessary.  

To check the document's validity and security properties, click the ‘Properties’ button 
on the reader toolbar or go to ‘File’ > ‘Properties’. This will show you details about the 
document's issue date and validity, as well as information about the issuer. 

 

Figure 14: Document Properties  

 

Figure 15: Document Validity Details 

Similarly, click the ‘Security Properties’ tab to see allocated print quota and other 
relevant information. 
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Figure 16: Document Security Properties 
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7 How to print a document using DDR? 

Keeping the document opened, to print, click on the print button or go to File > Print. 
This will open a Secure Print dialog that resembles the print dialog you’ve seen in 
other applications. 

The Secure Print Dialog allows you to print the document with all security features, 
such as a watermark, 2D barcode etc.  

Note: A compatible printer is required to print document with security features, you 
can find more details in the “Printer Requirements” section.  

Here’s a brief overview of each section of the Secure Print Dialog, which you can 
refer to reducing errors and achieving an optimal quality printout. 

 

Figure 17: Secure Print Dialog 

 

Secure Print Dialog explained in detail in the order marked in the figure: 

(1) Available Printers – it will show a list of available printers. To print, select the 
desired printer and click Print.  
This section of the print dialog will only show printers that are compatible with the 
security features. 
A valid printer will be indicated by a printer icon, while a red 'cross' icon typically 
signifies an issue/error with the printer. Ensure the printer is not in an error state, 
is using a valid port (e.g., IP address), is online, and is not busy processing any 
jobs. 
 
 

(2) Status - to see any general issues with the printer like ‘offline’, ‘error’, ‘paper jam’ 
etc, select the printer from the list (1) and scroll the ‘Status’ list, for errors.  
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If an error status is displayed, the user should check the printer queue (spooler) 
and inspect the printer for potential issues such as paper jams, low toner, or being 
out of paper. 

 
It can only show issues from the spooler. If you're unsure about the printer's 
status, perform a test print (by clicking ‘Test’ (4) button) to check if the printer is 
functioning properly.  
The test print will generate a standard Windows test print page. 
 

(3) Copies – the print quota is usually set to 1. 
 

(4) Test - to perform a test print click ‘Test’, this will print a windows driver page, 
perform a visual inspection on the test print page for quality issues before printing 
a document with all the security features. 
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8 What are the Printer Requirements? 

Requirement for optimal printing and to print security features: 

Printer Driver 

Requirement 

Printer Driver must be a PostScript-enabled driver.  

Please contact your printer vendor for the latest 

PostScript-enabled driver. (Typically, has “PS” as 

suffix/prefix in the printer-driver name)  

Printer Connectivity The Digital Document Reader (DDR) can only print secure 

documents using USB, LPT, DOT4, or valid TCP/IP ports.  

Make sure the TCP/IP ports don’t have any prefixes or 

suffixes (like IP_123.123.123.123 or 123.123.123.123_1). 

Note that shared USB printers won’t work, and shared 

network printers must be reachable (able to be pinged) by 

both computers. 

Printer Availability  When printing through DDR, the printer queue must NOT 

be in paused or offline state.  

Additionally, the printer must be online, and the print 

queue must be empty to allow printing.  

Printer Compatibility Please refer to the printer compatibility list published on 

the application portal or check with application support 

team.  

Watermark Printers Compatibility List 

 

  

https://licence1.business.gov.sg/feportal/web/help-internet/watermark-printers-compatibility-list
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9 Support Information 

All support requests shall be sent to: licences-helpdesk@crimsonlogic.com.sg 

Indicate in the subject of the email: [Product]-Brief problem description   

e.g., Subject: [DDR] – Unable to open the document. 

Describe in the email body any relevant detail information, screenshots, or log file (if 
applicable) so that CrimsonLogic can correctly resolve your support issues. 

10 Basic Troubleshooting 

10.1 Retrieve Logs 

Log files folder can be accessed from the DDR application menu; launch the application 
and navigate to Help > Open Logs Folder. If unable to access log files from DDR due to 
some issue like application crash etc.,  go to following location to retrieve the 
necessary log file: 

C:\Users\<your  device username>\AppData\Local\DigitalDocumentReader 

The log files are normally text files which look like this: 

 

Figure 18: Sample Logs files 

10.2 Application not running immediately after closed 

You may notice that the application doesn't start right away after you've closed it. DDR 
takes a few minutes to clear the cache and terminate any connections with the 
backend, so please wait a bit before trying to launch it again. 

10.3 Unable to print a secure document 

Ensure that no firewall, antivirus, or similar software is blocking the print job from being 
sent to the printer spooler.  If the print fails, click the print button or (File > Print) again 
to open the Secure Print dialog and select a valid printer to print. For further 
troubleshooting, refer Advanced Troubleshooting section.  

10.4 Reader showing update prompt 

If you see a dialog box indicating that an update is available while running the 
application, click 'Yes' to open the product page in Microsoft Store. Clicking ‘No’ will 
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close the reader and you won’t be able to open the document unless the reader is 
updated with a newer version. 

 

Figure 19: Sample Update Availability 

In Microsoft Store, go to Downloads: Click the "Get updates" button. The store will 
check for updates for all installed apps. 

Update Apps: If updates are available, they will start downloading and installing 
automatically. You can also manually update individual apps by clicking the "Update" 
button next to each app. 

Note: If you didn't install the app after signing in to the Microsoft Store, it might not 
appear under Updates & Downloads. In this case, you need to manually uninstall the 
current version and then install the new version from the store. 
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11 Advanced Troubleshooting 

11.1 Reader not able to open the document even with an active internet connection 

 

Figure 20: Unable to connect 

Seeing above error or unable to connect error in the reader?  

If you can access the internet through your browser but the reader is showing 
unable to connect message, check if your network requires a proxy server. Make 
sure to configure this in the reader's settings. 

In an environment where a proxy is needed, ensure the application  is configured 
with proper proxy settings to access the internet.  

Note: If you're uncertain about whether you need a proxy for internet access, 
please consult your support/system admin personnels or drop us an email (refer 
Support Information section) to guide you further. 

Here are the steps to configure a proxy; you can choose the one that fits your 
environment. Launch the DDR application and navigate to File > Settings to enter 
the proxy details. 

(a) System Proxy  

The System Proxy uses the same settings as your web browser, such as Edge. 
This option doesn’t require any configuration, as the app will automatically 
determine the necessary proxy server address and details for internet access. 

To check if a proxy is being used by the Edge browser, follow these steps: 

i. Open Windows Search: Click on the search bar in the taskbar. 

ii. Type "Internet Options": Enter "Internet Options" and select it from the 
results. 

iii. Go to the Connections Tab: In the Internet Properties window, click on the 
"Connections" tab. 
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iv. Click on LAN Settings: Here, you can see if a proxy server is enabled. If 
the "Use a proxy server for your LAN" option is checked, a proxy is in use. 

 

 

Figure 21: Internet Properties of Edge browser 

 

Figure 22: System Proxy Settings (DDR) 

(b) Configure Manually – (with username / password) 

To manually set up a proxy with credentials different from your windows login, 
enter the full proxy address, including 'http' or 'https', along with the necessary 
port. Choose the 'User supplied' option to input the 'Username' and 'Password' 
for proxy authentication.  

Make sure to use a valid username and password that have been provided to you 
for this purpose.  
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Figure 23: Manual Proxy Settings with Username & Password 

(c) Configure Manually – (Use Windows Credentials) 

When you use Windows credentials, the system automatically uses your existing 
login information (username and password) to authenticate with the proxy server. 

 

Figure 24: Manual Proxy Settings to Use Windows Credentials 

(d) Configure Manually – (No Authentication) 

Some proxy servers do not require a username and password. In such cases, 
select the 'No Authentication' option to configure the proxy. 
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Figure 25: Manual Proxy Settings with No Authentication 

11.2 DDR Installation failure 

Installation failure: Digital Document Reader requires .NET 4.8 to work properly. 
Though, setup holds the instructions to download the required framework from 
Microsoft Website, in an instance where the installer does not access the internet or 
unable to access the .Net framework installer, it is advisable to download and 
install.NET 4.8 framework manually and continue with the DDR installation. 

You can download the .Net Framework using the link below: 

https://dotnet.microsoft.com/en-us/download/dotnet-framework/net48 

11.3 Unable to run the application 

Unable to run the application:  Even after a successful installation, if the application 
does not run, it is recommended to remove the installed version and perform 
installation of .NET 4.8 first and re-run the Digital Document Reader installation to 
perform a clean installation. 

11.4 Unable to resolve the issue 

Try the step 11.2 first and if the issue continues and you can't resolve it, please reach 
out to the application support/ helpdesk team via email. Be sure to include a 
screenshot or a description of the problem, along with the logs from when the issue 
occurred. 

11.5 Printer not shown in the printer dialog (Secure Print Dialog) 

Printer not shown in the printer dialog:   

Firstly, ensure logged-in user is permitted to access the printer, to verify printing is 
allowed, go to:  

“Control Panel” > “Devices and Printers” [Windows 11]  or  “View Devices and Printers” 
[Windows 10]   
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Select the desired printer from the list, click the ‘Printer Properties’ and click ‘Print Test 
Page’ to perform a test print: 

 

Figure 26: Printer Properties Dialog 

Secondly, Ensure that the printer supports the required 600dpi resolution and uses a 
PostScript driver (contact your printer vendor for more information to install required 
PS driver), ensure that the printer is running on a USB, LPT, COM, DOT4 or a valid 
Network port. To check the port configured, click on the ‘Printer Properties’ (refer the 
step above), select the ‘Ports’ tab and verify required port is selected or not. 

 

Figure 27: Printer Port 

Thirdly, ensure right driver is selected, make sure the driver is either, a discrete 
PostScript driver or a Universal Print Driver that supports PostScript.  
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Note: You may wish to contact the printer vendor to be sure the driver is a proper 
PostScript driver, and that the driver is compatible with your printer. 

 
Figure 28: Printer Driver  

11.6 Optimal Printer Settings (if necessary) 

Go to the ‘PCP Settings’ tab in the Settings dialog. If a user has previously installed or 
used Print Control Proxy (PCP) for secure printing, this field will be filled in 
automatically. This identifier helps ensure the reader achieves optimal print quality as 
configured for PCP. 

Note: If you know that PCP has been used previously but no information appears in the 
settings, please send us an email to verify the PCP settings for you. Use only if 
instructed by the product/support team. Entering any random values may cause print 
errors or result in suboptimal printing. 

 

Figure 29: Print Control Proxy Identifier 
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12 Product update  

Application updates shall be made available through the same trusted website or 
source from which the application was initially downloaded, or through the Microsoft 
Store, ensuring the integrity and security of the software. To check whether any 
update is available, go to Help > Check for Updates, which will open the Microsoft 
Store for you. Refer 10.4 for further information on how to download and perform an 
update. 

13 License Agreement 

CrimsonLogic Product License Terms | Phidelity 
(https://phidelity.crimsonlogic.com/crimsonlogic-product-license-terms) 

 

https://phidelity.crimsonlogic.com/crimsonlogic-product-license-terms

